SeaDoo Spark Forum banner

21 - 40 of 46 Posts

·
Registered
Joined
·
104 Posts
Keep in mind that some standard sizes will fit a metric. They are not exact so you could end up tearing up the head when you get it tight or are trying to free the bolt.
 

·
Registered
Joined
·
185 Posts
Keep in mind that some standard sizes will fit a metric. They are not exact so you could end up tearing up the head when you get it tight or are trying to free the bolt.
9/16 = 0.5625 inches, 13 mm = 0.511 inches, and I used 1/2 which is obviously 0.500, that's why I thought it was weird that Bane had to use 9/16. It is quite a bit bigger than 1/2 and 13mm.

Yep, my phone sent this...
 

·
Registered
Joined
·
14 Posts
Discussion Starter #25
You do, thought I could take the entire assembly out from the impeller housing but no, you have to pull off everything to to get to it
 

·
Premium Member
Joined
·
201 Posts
Nope, I got an iBR model and once you pull the pump, the wear ring is free. Impeller does not need to be removed from pump. This should be the way all Sparks are. It is sandwiched between the pump and pump shoe.

Yep, my phone sent this...
+1 same result with mine and I have Ibr as well.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #29
Same here you pull out the assembly but the impeller remains inside it's pump housing. The wear ring sits between the hull and jet pump assembly... If I could figure out how to remove the jet pump and iBR as one assembly, I could do it in ten minutes
 

·
Registered
Joined
·
8 Posts
I realize that this is an older thread but does anyone know how much this will cost to get done at the dealership? I am an idiot when it comes to tools and machines.

I had my new 2015 out for the first time yesterday and this happened to me. I was in the middle of the lake so I have no idea what could have got sucked in there but I am not excited about it breaking after 1 hour of use.
 

·
Registered
Joined
·
312 Posts
I just replaced my 50 hour wear ring as I noticed the takeoff thrust was starting to lag. I had not dont one before so I took my time. It took about 5 minutes to change out the wear ring . There are 3 nuts on the pump housing and 1 on steering linkage. Id be willing to bet I could do it less than 3 minutes with power tools. I imagine add another 5 minutes on my wifes IBR. It could be done on the lake shore in a pinch with a 13mm rachet wrench and 2 10mm wrenches. Im just going to make a kit so when i go on trips I can have a spare on board in case I ever have one break. Its pretty much the same as a belt on a snowmobile as far as having a backup. One should be prepared with a spare . I just wish my old seadoos were such a quick and simple job to do.
 

·
Registered
Joined
·
8 Posts
They want $770 to fix this!

I have ridden it for 1 freaking hour and I already have a $770 service bill. Harley-Davidson and Ducati ain't got **** on Sea-Doo apparently.

I will never ever step foot into a Sea Doo dealership again. Where is a good place to buy parts online? I'll just figure this **** out from YouTube videos. I need the wear ring and some seal around the pump...anyone know what that seal is all about? LOL This is going to be a steep learning curve.
 

·
Registered
Joined
·
306 Posts
Today I played in the wave after 1 hours at WOT I stopped. as soon as I stopped a big vibration started in the drive shafts I was sure I sucked a stick. I put it in touring mode drove for 5min and suddenly no more vibration. My wear ring is fine. I'll take a picture let me know what do you think. I forgot to take a picture when my pump was out but I'll take it from the grate.

Sent from my SGH-I337M using Tapatalk
 

·
Registered
Joined
·
32 Posts
Today I played in the wave after 1 hours at WOT I stopped. as soon as I stopped a big vibration started in the drive shafts I was sure I sucked a stick. I put it in touring mode drove for 5min and suddenly no more vibration. My wear ring is fine. I'll take a picture let me know what do you think. I forgot to take a picture when my pump was out but I'll take it from the grate.

Sent from my SGH-I337M using Tapatalk

This happened to me. Was cruising along normally, and all of a sudden loud vibration and high RPMS. thought it had to be the wear ring. Limped for like ten minutes, then kept it cruising at under 5000 rpms while dealing with the heavy vibration and it cleared after maybe 15 minutes. Gone. I have ordered a new wear ring and plan on replacing, hasn't been back in the water since. Its been 4-5 days.

I think the ring is coming in on monday, so I may try my luck with it this weekend on the water and see how it holds up.
 
21 - 40 of 46 Posts
Top