SeaDoo Spark Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
But here is the thing, If you disconnect the battery, reconnect the battery, and within 3 seconds push the start-stop button, it will crank and start and run with no apparent troubles.
When you push the start/stop button to stop, it will stop. But It will not start again.
It seems like the ski start relay and the fuel pump is energized whenever the battery is connected, the display is on constantly and it responds to button presses.
How I cycle the power on the ski is by pulling the 15 amp fuse - i might put a switch in line with this fuse so i can start this thing until I get it figured out.
any ideas would be great
additional
the display is on even if the key is disconnected. if the key is removed while the jet ski is running, the ski will stop.

Thank YOu
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
Yes, the battery is charged fully.
Is there a service manual? looking for the sequence of operations.
I assume when power is applied the ski will do a self-test if I try to start before self-test is finished it cranks/starts. If I wait until it's done with selftest it doesn't crank/start.
I am wondering if there is a problem with the LCD gages. It seems like the control thinks the ski is running, I see the wires going through this gauge set.
when you connect the battery the ski beeps twice the LCD does its little power-up thing and you can hear the fuel pump run for about 30 seconds. this is all with the key disconnected.
 

·
Registered
Joined
·
1 Posts
Did you ever figure this out? Mine is doing the exact same thing. Any thoughts or ideas greatly appreciated.
 
1 - 4 of 4 Posts
Top