SeaDoo Spark Forum banner
1 - 13 of 13 Posts

·
Registered
Joined
·
259 Posts
Discussion Starter · #1 · (Edited)
I have a 2015 2up, HO, IBR, VTS with just over 10 hours and the engine access panel rattles at idle when the ski is in the water. The panel has rattled from the first minute I took it out. If I hold my hand on the panel or slide it forward, up or down as much as possible the rattle will stop for a little while. Very annoying in an idle zone. When I speed up even a little bit, the rattle goes away.
It's difficult to tell over the engine noise but it might also rattle a little bit when sustaining speed in the 25-30MPH range.

I checked to make sure that nothing was in contact with the inside of the hull in the engine door area. There was a line running by there that was touching the hull and I used zip ties to move it away from the hull but the rattle persists.
Taking the spark for warranty work on something so minor feels like a hassle - I'd much rather be out riding. Not to mention the fact that it doesn't rattle when idling on the trailer.

Is there a quick fix for this?
Does anyone else have a 2015 with a rattling engine access panel?
 

·
Registered
Joined
·
516 Posts
Mine did it too when it was new. Now with 25 hours on it, it doesn't do it anymore. The only thing I can think of is I have removed and installed it a bunch of times now. So maybe it has broken in, or gotten more flexible.
 

·
Registered
Joined
·
259 Posts
Discussion Starter · #3 ·
Mine did it too when it was new. Now with 25 hours on it, it doesn't do it anymore. The only thing I can think of is I have removed and installed it a bunch of times now. So maybe it has broken in, or gotten more flexible.
Cormacs:

Thanks, hopefully that's all it is and it goes away on it's own. I'll be patient and give it a few more rides before I put too much effort into it. :cool:
 

·
Registered
Joined
·
165 Posts
I can confirm this on my spark too, Kind of annoying at times... I just give it a little kick now and then and it seems to help it a little bit. But a bigger problem is my handle bars squeak and are kind of stiff. should I just grease them?
 

·
Registered
Joined
·
259 Posts
Discussion Starter · #9 ·
I'm at just about 15 hours on my ski and the rattle does seem to have diminished quit a bit. Hopefully I'll get plenty of riding time in over the holiday weekend and it will go away completely.
 

·
Registered
Joined
·
259 Posts
Discussion Starter · #10 ·
Just thought I'd post an update.
At about 21 hours now.
The rattle is gone almost entirely. I only noticed it faintly for a few seconds while idling but then it stopped. Maybe the panel just had to settle into place after a few heat cycles?
 

·
Registered
Joined
·
516 Posts
Just thought I'd post an update.
At about 21 hours now.
The rattle is gone almost entirely. I only noticed it faintly for a few seconds while idling but then it stopped. Maybe the panel just had to settle into place after a few heat cycles?

I've had the same results


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
165 Posts
Just thought I'd post an update.
At about 21 hours now.
The rattle is gone almost entirely. I only noticed it faintly for a few seconds while idling but then it stopped. Maybe the panel just had to settle into place after a few heat cycles?
yeah I've got about 14 hours now and its just about gone for me too, my handle bars still squeak though.
 

·
Registered
Joined
·
131 Posts
Mine used to pop off a few times during a 2 hour stretch. It was replaced under warranty with another 2014 style cover, but it's very secure now. My old one didn't have any broken tabs, just never sealed very tight. Try having a new cover fitted, probably will go away
 
1 - 13 of 13 Posts
Top