SeaDoo Spark Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
So we just bought a 2018 Seadoo Spark, perfect condition, only had 10 hrs and recently had a oil change I believe. Rode it for the first time yesterday, runs great. My sister got on it for the first time and when she was heading back towards our house she hit the shore and probably sucked up some rocks. It made a rough grinding sound and I had to run over to her and shut it off. After that it wouldn’t start. We got it out the water and shook the back off to see if any rocks would come out. After that we got it back in the water and it started up just fine. However, after that incident it’s only topping out at 34 mph with 8500 rpm on full throttle, on both tour and sport mode. So what should we do? I’ve head about that’s the wear ring is probably damaged.
 

·
Registered
Joined
·
3 Posts
So we just bought a 2018 Seadoo Spark, perfect condition, only had 10 hrs and recently had a oil change I believe. Rode it for the first time yesterday, runs great. My sister got on it for the first time and when she was heading back towards our house she hit the shore and probably sucked up some rocks. It made a rough grinding sound and I had to run over to her and shut it off. After that it wouldn’t start. We got it out the water and shook the back off to see if any rocks would come out. After that we got it back in the water and it started up just fine. However, after that incident it’s only topping out at 34 mph with 8500 rpm on full throttle, on both tour and sport mode. So what should we do? I’ve head about that’s the wear ring is probably damaged.
Definitely going to be the wear ring if you've sucked up some rocks
 

·
Registered
Joined
·
5 Posts
So we just bought a 2018 Seadoo Spark, perfect condition, only had 10 hrs and recently had a oil change I believe. Rode it for the first time yesterday, runs great. My sister got on it for the first time and when she was heading back towards our house she hit the shore and probably sucked up some rocks. It made a rough grinding sound and I had to run over to her and shut it off. After that it wouldn’t start. We got it out the water and shook the back off to see if any rocks would come out. After that we got it back in the water and it started up just fine. However, after that incident it’s only topping out at 34 mph with 8500 rpm on full throttle, on both tour and sport mode. So what should we do? I’ve head about that’s the wear ring is probably damaged.
Yup..like a transmission slipping.
 
1 - 5 of 5 Posts
Top