SeaDoo Spark Forum banner
1 - 18 of 18 Posts

·
Registered
Joined
·
131 Posts
Discussion Starter · #1 ·
It seems this isn't a common issue, but I thought it possibly was? My spark and all of my friends have excessive play in our handlebars. Does anyone else have this? Where when new you couldn't move them forward and backwards, but over time they have become more and more loose?
 

·
Registered
Joined
·
516 Posts
I just checked both of mine. They both have about an 1/8" of moment fore and aft. It's hard to tell if it's play or the plastic flexing. Ones a 14 and ones a 15. I'll keep an eye on them to see if they get worse but I would consider it normal. I have to go to the dealer tomorrow to replace a lost tether, I'll check one in the showroom.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
131 Posts
Discussion Starter · #4 ·
I just checked both of mine. They both have about an 1/8" of moment fore and aft. It's hard to tell if it's play or the plastic flexing. Ones a 14 and ones a 15. I'll keep an eye on them to see if they get worse but I would consider it normal. I have to go to the dealer tomorrow to replace a lost tether, I'll check one in the showroom.


Sent from my iPhone using Tapatalk

Mine had no movement when new, I confirmed this with four new sparks at the dealer yesterday too.


I've read on here about the same thing so just assumed it was a widespread issue because all of my friends have the same issue. They all move about a inch or so, and squeak like crazy.
 

·
Registered
Joined
·
516 Posts
I'll agree the squeak is common. A few have fixed it with a little silicone grease. The bushing at the top seems to dry up and squeak.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
80 Posts
The bushes flog out my dealer is replacing heaps after about 50 hours. Another reason I put the WORX steering in aftermarket bushes that won't flog.
 

·
Registered
Joined
·
131 Posts
Discussion Starter · #7 ·
The bushes flog out my dealer is replacing heaps after about 50 hours. Another reason I put the WORX steering in aftermarket bushes that won't flog.

I don't feel crazy now, and feel like me and my friends have only had this issue!

Ours all started well before 10 hours though.
 

·
Registered
Joined
·
165 Posts
I've got about 10 hours on my 2015 spark now, It squeaks from time to time but no looseness. My 94' SPI had some wiggle in the handle bars though.
 

·
Registered
Joined
·
6 Posts
I have a 15 two up with avout 10 hours and just started squeaking in the steering as well. Anyone know if thw 15s already had steering recall problem performed?
 

·
Registered
Joined
·
516 Posts
The 15's have no recalls, but just about all have developed the squeak at some time. I usually just lube it up with some silicone spray in a can.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
80 Posts
Its a simple job pull out your steering stem and put some grease in the bushes . you will be amazed at how free the bars will turn and no more squeaks.
 

·
Registered
Joined
·
80 Posts
I don't feel crazy now, and feel like me and my friends have only had this issue!

Ours all started well before 10 hours though.
You and your friends must ride like crazy. lol. The wave jumping crew here are getting about 40 hours before they notice.
I put WORX stem in after first ride so I don't have the problem.
 

·
Registered
Joined
·
131 Posts
Discussion Starter · #13 ·
You and your friends must ride like crazy. lol. The wave jumping crew here are getting about 40 hours before they notice.
I put WORX stem in after first ride so I don't have the problem.
Yeah it's weird, none have seen an ocean either. All have been used on a man made lake
 

·
Registered
Joined
·
131 Posts
Discussion Starter · #15 ·
I'm wondering if somehow my friends and I have a bad batch of skis? Done here say our handlebars having tons of play is not the majority.... All of our access panels pop off in heavy wakes too
 

·
Registered
Joined
·
516 Posts
I'm wondering if somehow my friends and I have a bad batch of skis? Done here say our handlebars having tons of play is not the majority.... All of our access panels pop off in heavy wakes too

That was a 2014 issue they fixed it by putting a lock on the 2015's. The panels are interchangeable so people that have a 2014 that have the issue are buying 2015 panels and using them.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
131 Posts
Discussion Starter · #17 ·
That was a 2014 issue they fixed it by putting a lock on the 2015's. The panels are interchangeable so people that have a 2014 that have the issue are buying 2015 panels and using them.


Sent from my iPhone using Tapatalk
Yeah that is probably the best solution. My dealer told me it's very common and they have been replacing them? Maybe with 2015 ones?
 

·
Registered
Joined
·
516 Posts
Probably. I have both a 15 and a 14 although I haven't had this issue yet I tried swapping them to see if they are interchangeable for someone o here. My 15 cover fits on my 14 and locks just like it was a 15


Sent from my iPhone using Tapatalk
 
1 - 18 of 18 Posts
Top