SeaDoo Spark Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1 (Edited)
2 Up spark, 15 hrs of aggressive riding, broke down yesterday. Fell off the spark after a 180. Swam and boarded, started up fine, idled fine, but with any throttle a high pitched whining noise (shaft spinning noise), and no propulsion. The idle mode moved spark slowly through water, and back to dock and trailer. I could see nothing in grate, I could see the propeller clearly. I brought it t the dealer, and will update board when I hear from them. Any thoughts? On the plus side, dealer mechanics comments were all along the lines of "we finally get to open one of these up" (implying not many of them are coming back for service).

First Update: Word from dealer is that the wear ring looks fine.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #2
Second update: So what they found was the splined area where the drive shaft mates with the impeller shaft was stripped. They have ordered new parts, have to take the engine quite apart to get to it all, and hope to have it to me for the weekend. All warranty, and SeaDoo has asked for the damaged parts top be shipped to a specific engineer to try to determine how it could have happened.
 

·
Registered
Joined
·
81 Posts
Interesting , this will be a first stripped on the engine shaft input ...
 

·
Premium Member
Joined
·
137 Posts
It's assembled in Mexico. I wonder how well they put stuff together
 

·
Registered
Joined
·
916 Posts
On the plus side, dealer mechanics comments were all along the lines of "we finally get to open one of these up" (implying not many of them are coming back for service).[/QUOTE

wow that's crazy. My dealership charged me about $200 as one of their BS add on fees and surcharges and said all sparks were opened up, checked over thoroughly and sprayed with a rust / corrosion protection film.

I guess they didn't do that there.

Glad your problem was solved and it was covered by warranty. also glad you have a trailer and vehicle. sorry you were 9 days without your toy! its $150 round trip if i need to get mine fixed!
 

·
Registered
Joined
·
4 Posts
I had the Exact Same thing

Wow, I had the exact same thing happen, my spark had 13 hours on it of toned down break-in riding on it.

And from what the dealer said after talking with BRP this is happening a LOT! The parts are now on back order to make the repair.

I know Sea Doo was shooting for fun and cheap with the spark, unfortunately I think they nailed down the cheap part and now it's no fun:(
 

·
Registered
Joined
·
274 Posts
Really?!? I just checked with my dealer and he said there was 75 drive shafts in stock right now, and more to arrive in the next two weeks and there were over 350 impellers in stock!
He hasn't heard of a single one having any issues what so ever!
 

·
Registered
Joined
·
20 Posts
@ mikeallard... i am glad you posted this. I am currently going through the same issue on my 2up HO spark. my shaft threads wore out and also so did the impeller threads. I had same problem and posted about it a week or 2 ago. The part numbers are 267000584 impleller and 271001761 the drive shaft. BRP is saying this is something that isn't covered. IF you don't mind can you private message me your case number with BRP so i can reference it with my case handler. I would assume mine would be covered under the warranty if yours was. I just got the news today.
thanks
 
1 - 11 of 11 Posts
Top