SeaDoo Spark Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 · (Edited)
The BRP speaker I received with my 2019 spark trixx has stopped working. I had used the speaker briefly, and it all worked fine. When I have then gone to charge the speaker prior to taking the ski out, the lights illuminate indicating it’s charging. However when I unplugged it from the charger the speaker now has no life and won’t turn on what so ever.

Has any one else had this issue? Or does anybody have any idea what may be the problem?

Thanks!!!
 

·
Registered
Joined
·
2 Posts
The BRP speaker I received with my 2019 spark trixx has stopped working. I had used the speaker briefly, and it all worked fine. When I have then gone to charge the speaker prior to taking the ski out, the lights illuminate indicating it’s charging. However when I unplugged it from the charger the speaker now has no life and won’t turn on what so ever.

Has any one else had this issue? Or does anybody have any idea what may be the problem?

Thanks!!!
 

·
Registered
Joined
·
2 Posts
I’ve got two speakers. Both 2019/2020 models and one has kicked the bucket. It went working to working Great to working for 15 minutes.
I charge it for days and the blue light never turns any other color.
Now when I unplug it it won’t even turn on.
Any idea where you send these for repair?
 

·
Registered
Joined
·
1 Posts
The BRP speaker I received with my 2019 spark trixx has stopped working. I had used the speaker briefly, and it all worked fine. When I have then gone to charge the speaker prior to taking the ski out, the lights illuminate indicating it’s charging. However when I unplugged it from the charger the speaker now has no life and won’t turn on what so ever.

Has any one else had this issue? Or does anybody have any idea what may be the problem?

Thanks!!!
Hey man, did you ever find a solution to this, I just recently had the exact same problem and am trying to find a way to fix it
 

·
Registered
Joined
·
2 Posts
The BRP speaker I received with my 2019 spark trixx has stopped working. I had used the speaker briefly, and it all worked fine. When I have then gone to charge the speaker prior to taking the ski out, the lights illuminate indicating it’s charging. However when I unplugged it from the charger the speaker now has no life and won’t turn on what so ever.

Has any one else had this issue? Or does anybody have any idea what may be the problem?

Thanks!!!
yes mine stopped charging as well.........I have used it maybe five times and it is toast. There is no support from seadoo and no one that I could find to fix~
 

·
Registered
Joined
·
2 Posts
I took it to a couple of electronics stores, but the unit is sealed together so tight and taking off the center speaker does create a small hole to access the guts but its a **** show for anyone to get back to where the power supply is located to fix it! And that's if you can find the parts. These speakers were designed by Miteck Corp, but BRP chose to not use them and instead made the speakers themselves through an undisclosed OEM. I just decided to buy a new one........here is the best price I could find.....https://leadersrpmshop.com/sea-doo-new-oem-system_audio-bluetooth-kit-295101042/?gclid=Cj0KCQjw54iXBhCXARIsADWpsG_mRJCvMHw3ALoUbAeHuema61tPLWp8kUq1NdMOmSCrQfGcBOKBxpYaAjzoEALw_wcB
 

·
Registered
Joined
·
1 Posts
I had the same problem with the BRP Audio system that came factory on the Trixx. It would show a blue light like it was charging, but wouldnt stay on long enough to sync with phone. My Dealer worked hard to try and get it covered, but Sea Doo wouldnt. They did have me try a new charger and it worked!! I couldnt believe it, but the battery in mine was fine, it was the **** charger. So, you may wanna try that before cracking open the speaker. Good Luck, Hope this helps someone!!
 
1 - 10 of 10 Posts
Top