SeaDoo Spark Forum banner

1 - 20 of 34 Posts

·
Premium Member
Joined
·
768 Posts
Discussion Starter #1
Actually, that would be an understatement. I just checked the oil level in the ski because we went out on it Saturday for the day and wanted to take it out tomorrow. Luckily I did that because the oil is not even registering on the dip stick.
The problem I have now is getting oil for the ski on a holiday! Any one have any ideas? We wanted to head to the ramp by 6am to beat the crowds and be in by noon when everyone is out.
 

·
Registered
Joined
·
191 Posts
any SN rated 5W 40 to top off- MobilOne comes to mind, hit your wal-Mart! should maybe even be watercraft oil there too!

Question is why did it use oil??? The sump is small and w/ high RPM's, keep it near/at full! Check often & how? it's all in the manual under the seat!
 

·
Premium Member
Joined
·
768 Posts
Discussion Starter #4
OK, Thanks Jeffin. Guess I should have read my manual first before panicking. lol Like you said I am going to run over to wallmart to get the oil. Do you think I should still be worried about the fact that it is that low already?
 

·
Registered
Joined
·
191 Posts
yea, I'm concerned, check it several times (see manual for procedure), add in increments...keep an eye on it.

I can't seewhy other than a minimal amount for initital break in till rings seat it would use ANY? anybody else noticing oil burn off?

Think of changing it at 25~ hours IF it keeps using...then leaks/loose filter could be spotted and fresh oil may stop the use after break in...

Any oil in bilge? get a flashlite and look around...
 

·
Premium Member
Joined
·
768 Posts
Discussion Starter #6
Sound advice. I will fill it tonight and after tomorrow's run, remove the top and inspect. Thanks for the help.
 

·
Registered
Joined
·
227 Posts
yea, I'm concerned, check it several times (see manual for procedure), add in increments...keep an eye on it.

I can't seewhy other than a minimal amount for initital break in till rings seat it would use ANY? anybody else noticing oil burn off?

Think of changing it at 25~ hours IF it keeps using...then leaks/loose filter could be spotted and fresh oil may stop the use after break in...

Any oil in bilge? get a flashlite and look around...

Dealer add oil when commissioning from what I understand.it was probably low out of the gate . Also check level with warm engine and in the water so it's level.
I changed oil only at 10 hours although Sea Doo doesn't call for it.
 

·
Registered
Joined
·
191 Posts
mine was delivered 1/2 way tween add and full marks...I also tend to think it was dealer not topping off properly as per delivery inspection sheet (under seat w/ manual, dealer supposed to remove, complete, keep copy, copy you and one to BRP)

So much for that "freight and set up fee" LoL...
 

·
Registered
Joined
·
247 Posts
It should be 1/2 way between Full and Low and if its Not registering on the stick DO NOT go overboard with adding additional Oil- TOO Much is just as bad or worse as Not quite enough?
 
  • Like
Reactions: Sparkmats

·
Premium Member
Joined
·
768 Posts
Discussion Starter #11
Mark: Now that you mentioned it. After I rode it maybe twice I checked the oil and it was in between low and full. Same as yours. So, yeah, nice set up fee :rolleyes:
I got oil last night and filled it up to the full mark. Heading out in a little bit. :cool:
Thanks for everyone's input.
 

·
Premium Member
Joined
·
201 Posts
Very interesting..something to definitely give the dealer a call about. Btw I'm at 12 hours now and oil level still showing full.
 

·
Premium Member
Joined
·
768 Posts
Discussion Starter #16
Well guys, was out for maybe an hour. I hear a tapping noise already and when I got back to the house and checked, the oil level had gone down again. Not sure if it should be burning that much oil already.
 

·
Premium Member
Joined
·
201 Posts
Well guys, was out for maybe an hour. I hear a tapping noise already and when I got back to the house and checked, the oil level had gone down again. Not sure if it should be burning that much oil already.
That's not a good sign, since it's new and your under warranty I would take it to the dealer, ideally you should not be burning very much oil if none at all. Are you noticing any colored smoke coming out of the exhaust?
 

·
Registered
Joined
·
191 Posts
yea, you got a broken ring or something very wrong, that's gonna be a teardown issue. Remind them the oil is really going through it fast. Let us know how dealer handled, what info they got from BRP and maybe if a new unit might be the best option if your still very low on hours.
 

·
Registered
Joined
·
236 Posts
That's a little disconcerting. Low oil is something I would expect from my 100,000 mile 6 year old Jeep Wrangler JK, not first year new from a Sea Doo. Any one hear if Ski-Doo riders have reported the same thing with the Rotax 900? Wasn't our Rotax used their first in the frozen north in Snow Machines?

But Def take it back for warranty. I'd be upset.:mad:
 
1 - 20 of 34 Posts
Top