SeaDoo Spark Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
Hello everyone. Purchased my first Sea Doo watercraft a few weeks ago for use in the Sacramento River. Two Sea Doo Sparks. 2-up HO engine. Licorice. They get a lot of attention and I love riding them. However, in only 4 trips to the river, I have jammed the impeller with debris three times and also had a faulty sensor that put the ski into limp mode. Sensor has been replaced and I am back in action. For the time being. Trying to be optimistic that these things will not require too much maintenance and headache. I purchased new to avoid the maintenance hassles and headaches. So far not so good...
 

·
Registered
Joined
·
48 Posts
first up welcome aboard, second up sucking up debris is not a mechanical issue that can be chalked up to used/new ski. Truthfully its rider responsibility to not suck up debris ;)

But welcome up, treat them right and you'll see no issues, just ask some of our veterans ;):D
 

·
Registered
Joined
·
10 Posts
Discussion Starter #4
first up welcome aboard, second up sucking up debris is not a mechanical issue that can be chalked up to used/new ski. Truthfully its rider responsibility to not suck up debris ;)

But welcome up, treat them right and you'll see no issues, just ask some of our veterans ;):D
Thanks for the reply. I suppose I wasn't expecting a plastic water bottle cap or a stick the size of a cigarette to present a problem for my impeller. Maybe I should look more carefully? :eek: But I'm not sure my eyes are that good, especially above 10 mph. All of the items were so small. I guess it's something I have to deal with being on a dirty river.
 
1 - 5 of 5 Posts
Top