SeaDoo Spark Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
I have a 2018 with about 40 hours on it now. It now has a display that is not working and also it will start but does not go through the start up sequence and beeps. When I press the start button it will engage the starter. I just unplugged the display and it still starts but it did not alter anything. The machine just goes right to starter engagement. I was thinking about swapping displays and see if it has something to do with the display or if the problem is coming from something else.

Does anyone have any experience with this? I also swapped starter relays and it did not change anything and all fuses are good.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #2
Update, I was thinking that I had a bad display and an ECM problem, I just pulled my good display off my other machine and plugged it into the machine with the damaged display. The good display fired up and it also solved the no beep problem. The start up sequence is tied to the display and it seems to function normally. So now I am on the hunt for a replacement display. I also did another wear ring swap out. This is the second one in a week.. So make sure to push out or keep the rpms down until you have enough depth to prevent rocks from being sucked up off the bottom. The wear ring and seal from the dealer came to just under $90.00. I ordered an extra off amazon at $39.00. It just takes a couple weeks to get here. I did purchase the seal but I am keeping that as a spare. I reused the old seal off the wear ring. Normally i think the seal is protected and you should not have to replace the wear ring seal and should be able to just keep using the old seal ring.
 
1 - 2 of 2 Posts
Top