SeaDoo Spark Forum banner

Power but no accelaration

11494 Views 4 Replies 5 Participants Last post by  NJspark33
Im having problems with acceleration. The engine sounds ok but the seadoo is only moving forward at about 5mph even when im accelerating. Ive rocked it side to side continuously but no change, any other ideas?
1 - 5 of 5 Posts
Checked your wear ring?

Sent from my iPhone using Tapatalk
Yup.. I've seen that problem... Your wear ring is toast
I put mine in today, first time out.... seemed fine soon as i started it, couple little bursts to get a few mph near the dock... then tried the brake on the left, then tried to leave the dock and half throttle would only do 4-6mph... realized the **** ibr brake was down, so it was blowing the jet into the plate... came back to the dock, eventually just floored it wide open and it sprung back up suddenly and off i went.. maybe its that?
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.