SeaDoo Spark Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Just purchased a 2020 3 up with IBR. After about 7 hours, I ended up in more shallow water then I expected and sucked up a rock. Perfect.

I figured the wear ring was shot, so I purchased the RIVA stainless wear ring, and Solas 12/17 Prop. I started pulling the back off today, and found the rock lodged in between 2 impeller blades. Surprisingly the stock impeller is still ok, but looking deeper I found 2 vanes in the pump housing are torn right through. Assuming the lodged rock tore right through them.

I am looking online for pump housings, and am torn between if I need to fix it this year, and if I should go with stock or upgrade to the stainless stator vane pump assembly from Solas.

Is this a fix someone can do themselves? I don’t see a lot of information on people replacing these housings, and if they did it themselves.

my local dealer is about 4 weeks out on repairs so there goes the remaining good months of use if I bring it in.

Any insight is greatly appreciated!
10012
 

·
Registered
Joined
·
27 Posts
If it were me and those 2 vanes are just chipped away a little as the picture looks I'd smooth the edges and ride it as is for the rest of the season then take it to dealer for winter to get replaced. I usually find the upgrade part (Solas) costs about the same as a factory plain part from the manufacturer so i always opt for the better quality/ performance upgraded part.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
So I figured I would post an update in case anyone has a similar issue.....

Ended up ordering a 12/17 Solas Prop, RIVA SS wear ring. Located an online shop OSD Marine that builds the pump assembly. Opted for the Solas Stainless Pump Housing as well over stock. He builds the pump assembly and had it shipped in just a few days. Came in and was perfect. There is no way someone can build the pump assembly at home, requires leak testing and an assortment of tools. On top of that the service manual says most of the parts need to be replaced in the pump housing anyways if you take them out. Had to purchase the service manual and the various loctite and grease required. Generic Marine Grease off amazon, Anti Seize Loctite & Loctite 243. OSD supplies a tube of the pump grease.

The easiest way to do this with a 3up is pull the few screws from the extension platform and pull the extension deck off. There is no way to get sockets on it with the deck installed. Your gonna need torque wrenches as well.

If your gonna do it I would do all Solas/RIVA parts. The stock parts are junk. People arguing over the plastic wear ring hoping to save the “more expensive parts” that didn’t happen in my case. Stay out of shallow water, put SS.

Didn’t notice any changes in performance with the stock tune. I have no plans to tune this either. I think the RPM was lower then running the stock prop.

if you know your way around tools and working on vehicles this shouldn’t be an issue for you to do.

Hope this helps anyone who is in the same issue
 

·
Registered
Joined
·
2 Posts
Just purchased a 2020 3 up with IBR. After about 7 hours, I ended up in more shallow water then I expected and sucked up a rock. Perfect.

I figured the wear ring was shot, so I purchased the RIVA stainless wear ring, and Solas 12/17 Prop. I started pulling the back off today, and found the rock lodged in between 2 impeller blades. Surprisingly the stock impeller is still ok, but looking deeper I found 2 vanes in the pump housing are torn right through. Assuming the lodged rock tore right through them.

I am looking online for pump housings, and am torn between if I need to fix it this year, and if I should go with stock or upgrade to the stainless stator vane pump assembly from Solas.

Is this a fix someone can do themselves? I don’t see a lot of information on people replacing these housings, and if they did it themselves.

my local dealer is about 4 weeks out on repairs so there goes the remaining good months of use if I bring it in.

Any insight is greatly appreciated!
View attachment 10012
How did you even get the bolts off the bottom to get to the impeller? We can not get them off to see what is going on. think we have same issue with our spark trix
 
1 - 8 of 8 Posts
Top