SeaDoo Spark Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 · (Edited)
Was out driving with my Spark 2014 when the speed suddenly died. It went down to 3 mph. No error messages. All looked fine on the display. When I gave it some throttle, nothing happened with the speed, but the engine sounded like it was spinning.

First thought was that I must have gotten some sea weed and destroyed the wear ring. So i got towed home to check. Changed wear ring for safety (even though it looked good). Tested again on the water but still nothing happened. The engine sounds like it is spinning up but no speed at all.

Watch video here on how it sounds. Any ideas what it might be? :)
Video link

Thanks from Sweden
 

·
Registered
Joined
·
64 Posts
I can't see the water, is it actually going 5 or 6 mph or just floating in the water? Are you giving it more gas than just idle/ no wake speed? You may want to start it on the trailer with your phone under it to see if the impeller shaft is actually spinning. Maybe you have a stripped/ broken impeller (driveshaft basically) shaft or bad PTO that's not transferring power?
Something jammed in the pump would be the first thing I'd of looked for as that's happened to me with a stick jammed in there hard enough to ruin the stock aluminum impeller.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Thank you Jon. It moves on the water but just barely (Not 5 mph). I did start it on the trailer with a water hose connected. When I give it a little gas, it sprays more water so I guess the impeller is spinning (at least when it is not stressed). Will unmount the impeller to see the status and give you an update
 

·
Registered
Joined
·
13 Posts
So I just fixed a 2015 spark with same issues. First off. It’s your pto it’s stripped out inside the crank very bad!if you bought this ski recently you can try to get your money back . If you have had if for a while you can replace crank, it’s only option all the other bandaids don’t work we have tried them trust me.sea doo changed the pto design in 16 and made a new crank to stop the crank from stripping out.
I am in Montana and we could not find a shop that wanted to touch this job but they will sell you a whole new motor for 3500 or more .. you can replace ski for that price. We put a new crank in ours cost about 1300 bucks for parts. We work on a lot of engines and do a lot of wave runner stuff so we said piss on it and tore engine out and got busy.anyways point is that a your ski sounds like shaft is stripped. It doesn’t take anything for this to happen it really sucks for owners of 2014/2015 sparks.if your ski is in really good shape you might consider fixing it it’s not cheap but It’s hard to cough up more cash for new ski. Keep us posted as to what you find out.
If you lived closer to mt I would help you out good luck.
 
1 - 4 of 4 Posts
Top