SeaDoo Spark Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Loving the new 3 up 90hp spark! :D






Anyone know why the check engine light comes on when in chop or wave jumping? It turns back off in calm water and will go off immediately when you hit waves again. Would love to figure this out!
 

·
Registered
Joined
·
306 Posts
The only thing I can think of is the battery connection. You can make sure that they don't have corosion on them. Sorry can't help more.

Sent from my SGH-I337M using Tapatalk
 

·
Registered
Joined
·
274 Posts
Loving the new 3 up 90hp spark! :D






Anyone know why the check engine light comes on when in chop or wave jumping? It turns back off in calm water and will go off immediately when you hit waves again. Would love to figure this out!
not sure, its not normal, if it isn't putting it in limp mode it isn't anything too serious but I would want to get it scanned to see what it is...checking battery connections like Chuck said but also make sure you check the other end of the cable too.
 

·
Registered
Joined
·
4 Posts
mine is doing the same thing now. the first hour i rode it the 10A fuse blew due to a loose cable from the battery i assume. i tightened the cables, put in a new fuse and it runs good except going over big waves sometimes the check engine comes on, it beeps, and engine cuts out for a second then immediately seems to run normally. i was going to post about it, but i think this is the same as what you have posted. did you ever come up with a solution?
 

·
Registered
Joined
·
379 Posts
check fuses are tight fit and not lose


there was a fault with a batch of sparks where the loom up near the throttle body on the head chafing and earthing out causing faults maybe worth a look can do with top on with torch
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top