SeaDoo Spark Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
27 Posts
Discussion Starter · #1 ·
I took the top off to do some work and when I put it back on and reconnected the steering linkage, I noticed the bolt connecting the linkage seems to keep loosening itself. Located under the left side knee panel. Is it supposed to be completely tight or looser to allow for movement. I keep tightening it down but am afraid it's going to work itself out while out on the water and I'll have no steering. If it is supposed to stay tightened down, loc tite????
 

·
Registered
Joined
·
247 Posts
I did not use Loctite-Just Nice a firm Tightening!
 

·
Premium Member
Joined
·
768 Posts
When you re-installed it, did you place it inbetween the plastic piece or place it on top? If you look at it, The piece it goes into is shapped like a rectangle with one side cut out. The metal arm goes inbetween this and the bolt runs from the top thru the arm and secures from the bottom.
 

·
Registered
Joined
·
27 Posts
Discussion Starter · #6 ·
When you re-installed it, did you place it inbetween the plastic piece or place it on top? If you look at it, The piece it goes into is shapped like a rectangle with one side cut out. The metal arm goes inbetween this and the bolt runs from the top thru the arm and secures from the bottom.
Yup...sure enough I put it on top. Put it the right spot and tightened it down. Worked it back and forth for about 5 min. Seems to be holding. Thanks.
 
1 - 7 of 7 Posts
Top