SeaDoo Spark Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
47 Posts
Discussion Starter · #1 ·
Anyone know if the steering assembly has a bearing or such in it, that could become faulty. I noticed some gray grease right around where the steering sits into the ski. Almost looks like bearing grease. When i got home i examined and played with the steering and could hear a clicking in the cable. Confused as the cable connects to a pivot underneath of the steering.
 

·
Registered
Joined
·
115 Posts
Mine did the same after removing the top. I loosened the steering bolt slightly and moved the cable back and forth in the engine compartment. Still clicked, but not as loud. A couple rides later it disappeared


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
47 Posts
Discussion Starter · #3 ·
Yeah its weird. We're you riding kinda hard? This was my last planned ride of the season so I got into it a little more than normal haha. Did you notice any grease around the steering shaft?

Sent from my SAMSUNG-SM-G890A using Tapatalk
 

·
Registered
Joined
·
47 Posts
Discussion Starter · #5 ·
Mine did the same after removing the top. I loosened the steering bolt slightly and moved the cable back and forth in the engine compartment. Still clicked, but not as loud. A couple rides later it disappeared


Sent from my iPhone using Tapatalk
Yeah its weird. We're you riding kinda hard? This was my last planned ride of the season so I got into it a little more than normal haha. Did you notice any grease around the steering shaft?<br />
<br />
Sent from my SAMSUNG-SM-G890A using Tapatalk

Sent from my SAMSUNG-SM-G890A using Tapatalk
 

·
Registered
Joined
·
47 Posts
Discussion Starter · #6 ·
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top