SeaDoo Spark Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter · #1 ·
I had a weird experience out on the water yesterday and just though I'd share it. Maybe someone has experience this or have a suggestion. I was riding for about 30 minutes and came to an idle position and switch from touring mode to sport mode. A few minutes later I came to stop and tried to go but I went nowhere when I gave it throttle. It felt like the prop was spinning out of the water, that is the best way I can describe it. I let the ski go forward under its own power and tried a couple more times with same results. I believe after the 4th or 5th time it felt like something broke loose underneath and went on like nothing ever happened. I rode it for the next few minutes and everything felt normal. There was more debris out on the water due to some recent rains so the only thing I can think of is maybe something was stuck in the prop or jet area? After an inspection there is no visible damage or evidence of anything. Very strange. Any ideas? I'm going riding tomorrow we will see how it goes. 2015 3up, only 5 1/2 hours on it.
 

·
Registered
Joined
·
63 Posts
Sounds like cavitation(the formation of bubbles in a liquid, typically by the movement of a propeller through it).

Where were you riding? Was there seaweed floating around? Under your ski, is an open "vent" looking cutout, the intake grate. If seaweed is blocking this grate, and you try to accelerate, it will basically make turn you into a sitting duck.

You could have rode around and it just finally cleared it. Just try not to stop on top of seaweed, and if it happens again. You'll just have to jump in and clear it your self :p And if it's not seaweed, you've got a different problem.
 

·
Registered
Joined
·
196 Posts
I had a weird experience out on the water yesterday and just though I'd share it. Maybe someone has experience this or have a suggestion. I was riding for about 30 minutes and came to an idle position and switch from touring mode to sport mode. A few minutes later I came to stop and tried to go but I went nowhere when I gave it throttle. It felt like the prop was spinning out of the water, that is the best way I can describe it. I let the ski go forward under its own power and tried a couple more times with same results. I believe after the 4th or 5th time it felt like something broke loose underneath and went on like nothing ever happened. I rode it for the next few minutes and everything felt normal. There was more debris out on the water due to some recent rains so the only thing I can think of is maybe something was stuck in the prop or jet area? After an inspection there is no visible damage or evidence of anything. Very strange. Any ideas? I'm going riding tomorrow we will see how it goes. 2015 3up, only 5 1/2 hours on it.
Verify your intake grate to ensure its free from obstacles, second check your wear ring minor crack can cause loss of pressure, as well check your prop if its dented beyond it should be it can cause issue when jetting the water through one source to another. Once you know what your issue or your issue still occur let us know. :)
 

·
Registered
Joined
·
23 Posts
Discussion Starter · #4 ·
Update:
I've been riding the last couple of days (2hrs total) with no issues what so ever. I inspected everything I could and found nothing visible. Like Seadood said it could of been a short lived cavitation issue, who knows. Intake grate and wear ring look okay. Glad everything is normal at this time. Thanks guys for suggestions.
 

·
Registered
Joined
·
23 Posts
Discussion Starter · #5 ·
Update

Update:
I've been riding the last couple of days (2hrs total) with no issues what so ever. I inspected everything I could and found nothing visible. Like Seadood said it could of been a short lived cavitation issue, who knows. Intake grate and wear ring look okay. Glad everything is normal at this time. Thanks guys for suggestions.
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top