SeaDoo Spark Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I am having a heck of a time trying to get the connector off behind the information screen underneath the handlebars. The instructions say to insert a small flat screwdriver in the pry holes. However, doing that does not detach the connector.*

Has anyone else had an issue with this and could you please give me some advice on how to take it off please?

Thanks in advance!

It will not let me upload pictures dang it
 

·
Registered
Joined
·
516 Posts
Here is a picture of the connector unplugged. That red tab slides back maybe a 1/8" of an inch. Then once it is back you squeeze the tab in front of it and pull the connector off.



Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
307 Posts
getting the plug off the screen was the hardest part of the installation for us. The instructions need to explain how to do that and they don't.
the bit you're referring to in the instructions talks about how to get the white bit in Cormac's photo out but not how to get the plug out.

as Cormac mentioned, you pull the red tab down then there is another tab you need to push in while pulling down.
do that and it will pop out, and from there you put the screwdriver in to get the white bit to come out.
 

·
Registered
Joined
·
516 Posts
I think the issue is the instructions were made for a technician and not a do it your selfer. So a technician would have a good idea of unplugging the standard vehicle plug. The instructions are there for adding pins because it isn't a standard everyday procedure even for a technician.


Sent from my iPhone using Tapatalk
 
1 - 5 of 5 Posts
Top