SeaDoo Spark Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Hey all I need some sage advice . The wife sucked up some crud and broke the wear ring on her machine. I have replaced it before so that isn't the problem. At about 11 o'clock there is a plastic tube that comes out and feeds into the impeller housing . It goes to a plastic nut on the impellar section . That tube has broken on mine . So I have a gap between the ski and the housing and an open tube .

So can I just seal the hole with something or is important for other things ?
 

·
Registered
Joined
·
379 Posts
Hey all I need some sage advice . The wife sucked up some crud and broke the wear ring on her machine. I have replaced it before so that isn't the problem. At about 11 o'clock there is a plastic tube that comes out and feeds into the impeller housing . It goes to a plastic nut on the impellar section . That tube has broken on mine . So I have a gap between the ski and the housing and an open tube .

So can I just seal the hole with something or is important for other things ?

Try this I think it will work nothing to lose


http://www.greenhulk.net/forums/showthread.php?t=217071
 

·
Registered
Joined
·
247 Posts
Hey all I need some sage advice . The wife sucked up some crud and broke the wear ring on her machine. I have replaced it before so that isn't the problem. At about 11 o'clock there is a plastic tube that comes out and feeds into the impeller housing . It goes to a plastic nut on the impellar section . That tube has broken on mine . So I have a gap between the ski and the housing and an open tube .

So can I just seal the hole with something or is important for other things ?
I looked at my Online manual and there is really NO mention of the use or purpose of that hose with the Plastic nut you talk about - Wonder where the hose leads inside the hull? Maybe an expert will help!!!
 

·
Registered
Joined
·
274 Posts
if its the one right at the top of the pump its for the bilge siphon, it just has a plastic fitting that goes into the Venturi, water goes past the hole in the venturi where the hose connects and it creates a low pressure in the hose which pulls water out of the hull through a pick up at the back of the hull, the drain plug also hooks up to the siphon pickup.
 

·
Registered
Joined
·
191 Posts
if its the one right at the top of the pump its for the bilge siphon, it just has a plastic fitting that goes into the Venturi, water goes past the hole in the venturi where the hose connects and it creates a low pressure in the hose which pulls water out of the hull through a pick up at the back of the hull, the drain plug also hooks up to the siphon pickup.
Was just looking closely at the ars of my Spark and wondered the same thing about that, even looking thru shop manual didn't notice the black tube/plastic nut mentioned on jet removal (?)...so, does that tube pop out or need a fitting(s) loosened when removing the pump? Etc?

Do you normally replace the seal and anything else with the wear ring, or just the ring itself?

Figuring this is something we'll all have to do sometime, I was running at 5 mph with the same awful vibration as something in the (middle) of the Columbia River was ingested into my intake yesterday, several (re)starts, rocking and just driving it at slow-modest speed freed it, but, it took almost an hour, no compter warnings or anything, just the noise, vibration and slow speed whine (like a slipping and chattering clutch)...Inspection today reveals a very clean grate, nice impellar and nothing other than very light scratches I can see )via flashlight) on the wear ring and the jet looks great too, ...it runs fine now, no vibration, top speed 41-42, yada...flushed the exhaust, rinsed the bilge, checked the fluids, all fine...

thoughts??

A "sticky" with a well written, step by step removal of jet, wear ring replacement, seal inspection etc., would be a NICE add to this section btw...:)
 

·
Registered
Joined
·
274 Posts
yes the hose fits onto a plastic fitting in the venturi, its not clamped or anything it just pulls out of the venturi or pulls off the hose.

usually just the wear ring needs to be replaced, but look at the impeller when you pull the pump off, any bends nicks in the impeller will hurt performance.

as for having something in your jet pump causing a vibration/performance issue, there are all kinds of things that can get sucked up and cause a problem and then go away! I had a water bottle cap and a walnut shell in the same week get sucked up and stuck on the front edge of the impeller blade, both times it was very easy once I got under it and used a stick to flip them off the blade, got lucky both times no damage! I was in a 14ft speedster another time and sucked up a pair of jean shorts, they just covered the intake grate so it wouldn't do any thing more than an idle which got me back to the trailer!
 
1 - 6 of 6 Posts
Top